Les anciennes versions d'Android ne prennent pas en charge les sites Web sécurisés

Les anciennes versions d’Android ne prennent pas en charge les sites Web sécurisés

⌛ Reading Time: 2 minutes

Il y a beaucoup de gens qui se vantent de ne pas avoir besoin d’un smartphone mis à jour – ils peuvent se contenter de leur ancien. S’il s’agit d’un Android, cependant, ils pourraient être contraints d’acheter un nouveau téléphone l’année prochaine. Les anciennes versions d’Android antérieures à 7.1.1 Nougat ne fonctionneront plus avec de nombreux sites Web sécurisés.

Changement de certification sur Android

Récemment, l’organisation à but non lucratif Let’s Encrypt a annoncé que le 1er septembre 2021, son partenariat avec l’autorité de certification IdenTrust prendra fin. Il ne renouvellera pas le partenariat et utilisera à la place son propre certificat racine. La signalisation croisée par défaut pour le certificat d’IdenTrust s’arrêtera le 11 janvier.

Cela conduira à ce que certains sites Web sécurisés ne soient pas compatibles avec les anciennes versions d’Android, ce qui signifie qu’ils ne fonctionneront pas. Les utilisateurs obtiendront des erreurs de certificat lorsqu’ils essaieront de visiter ces sites Web. Ce sera un problème pour les 33,8% d’utilisateurs d’Android qui utilisent encore des versions Android antérieures à 7.1.1 Nougat.

Solutions pour éviter l’erreur de certificat

La première solution si vous souhaitez accéder à des sites Web sécurisés sur votre ancien téléphone Android est évidente : achetez un téléphone plus récent. Mais Let’s Encrypt a également recommandé d’utiliser Firefox pour résoudre la plupart des problèmes.

“Pour le navigateur intégré d’un téléphone Android, la liste des certificats racine de confiance provient du système d’exploitation – qui est obsolète sur ces anciens téléphones”, a expliqué l’organisation.

Actualités Anciens sites Web Android Monde

“Cependant, Firefox est actuellement unique parmi les navigateurs – il est livré avec sa propre liste de certificats racines de confiance. Ainsi, toute personne qui installe la dernière version de Firefox bénéficie d’une liste à jour des autorités de certification de confiance, même si leur système d’exploitation est obsolète.

Cela répondra aux besoins de votre navigateur, mais vous pouvez également avoir des erreurs de certificat lors de l’utilisation d’autres applications sur votre ancien Android, et dans ce cas, vous pourriez être bloqué en achetant ce nouveau téléphone que vous avez essayé d’éviter.

Si vous choisissez de télécharger Firefox pour essayer d’afficher des sites Web sécurisés sur votre ancien Android, vous voudrez peut-être vous renseigner sur ce qu’est le DNS sur HTTPS et si cela fait de Mozilla un « méchant sur Internet ».

How useful was this post?

Click on a star to rate it!

Average rating 0 / 5. Vote count: 0

No votes so far! Be the first to rate this post.