Ricevi notifiche via e-mail delle vulnerabilità di sicurezza nei plugin di WordPress

Primiți notificări prin e-mail cu privire la vulnerabilitățile de securitate în pluginurile WordPress
⏱️ 2 min read

In qualità di webmaster di un sito WordPress, la massima priorità è mantenerlo al sicuro. Con migliaia di plug-in nel repository di WordPress, tutto ciò che serve è solo un codice non valido in un plug-in per arrestare l’intero sito. Ti abbiamo mostrato alcuni dei plugin di sicurezza che puoi utilizzare per proteggerti e, per portarlo oltre, ora puoi configurare WordPress per inviarti notifiche e-mail quando viene rilevata una vulnerabilità di sicurezza nei tuoi plugin WordPress.

Vulnerabilità dei plugin è un semplice plugin per WordPress che scansiona attivamente i plugin installati e ti invia un avviso e-mail quando viene rilevata una vulnerabilità di sicurezza.

L’utilizzo è molto semplice. Una volta installato, vai su “Plugin -> Vulnerabilità dei plugin” per configurare le impostazioni.

Nella pagina delle impostazioni ti mostra un elenco di vulnerabilità trovate nei tuoi plugin esistenti installati e anche vulnerabilità note per le versioni precedenti di plugin esistenti.

Per ogni vulnerabilità rilevata verrà fornito un collegamento a un sito in cui è possibile leggere ulteriori informazioni a riguardo.

Nella parte inferiore della pagina Impostazioni, è presente un campo a discesa in cui è possibile abilitare un avviso e-mail quando viene rilevata una vulnerabilità di sicurezza. Basta modificare il menu a discesa in “Abilitato” e fare clic su “Salva modifiche”.

plugins-vulnerabilities-enable-email-alert

Ora ti invierà notifiche e-mail quando rileva vulnerabilità di sicurezza nei tuoi plugin.

Funziona davvero?

Per provarlo, ho scaricato la versione 1.5.5.1 di WordPress SEo (è stato rinominato Yoast SEO) che è noto per avere una vulnerabilità di scripting cross-site. E questo è quello che vedo nella pagina Plugin:

plug-in-vulnerabilità-rilevata-vulnerabilità

Nota: Le vulnerabilità dei plug-in attualmente coprono 345 vulnerabilità e verranno aggiornate non appena verranno scoperte più vulnerabilità.

Cosa fare se il mio plugin installato presenta una vulnerabilità di sicurezza?

Se hai ricevuto un avviso e-mail da Plugin Vulnerabilities, la prima cosa da fare è aggiornare rapidamente il plugin all’ultima versione. Se è già l’ultima versione e non ci sono soluzioni da parte dello sviluppatore, sarà necessario disattivare il plug-in e cercare un’alternativa migliore e più sicura.

Conclusione

Se tendi a non preoccuparti troppo della configurazione di WordPress e / o non hai abilitato l’aggiornamento automatico in background per i plugin, questo sarà un plugin utile per te in quanto ti terrà informato sulle vulnerabilità di sicurezza del tuo sito. Facci sapere se lo trovi utile.

Join our Newsletter and receive offers and updates! ✅

0 0 votes
Article Rating
Avatar di Routech

Routech

Routech is a website that provides technology news, reviews and tips. It covers a wide range of topics including smartphones, laptops, tablets, gaming, gadgets, software, internet and more. The website is updated daily with new articles and videos, and also has a forum where users can discuss technology-related topics.

Potrebbero interessarti anche...

Subscribe
Notificami
guest
0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x